use strict;
my $str = '"name": "john doe"';
my $regex = qr/\s\"[^\"]+"/p;
my $subst = 'xxx';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";