#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.\d{3}$"
Local $sString = ".123" & @CRLF & _
"" & @CRLF & _
".000" & @CRLF & _
"" & @CRLF & _
".999" & @CRLF & _
"" & @CRLF & _
"And want false for these cases" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"" & @CRLF & _
"a123" & @CRLF & _
"" & @CRLF & _
".123a" & @CRLF & _
"" & @CRLF & _
".1234" & @CRLF & _
"" & @CRLF & _
"a.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")