import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.\\d{3}$";
final String string = ".123\n\n"
+ ".000\n\n"
+ ".999\n\n"
+ "And want false for these cases\n\n"
+ "123\n\n"
+ "a123\n\n"
+ ".123a\n\n"
+ ".1234\n\n"
+ "a.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}