$re = '/^\.\d{3}$/m';
$str = '.123
.000
.999
And want false for these cases
123
a123
.123a
.1234
a.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);