package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\.\d{3}$`)
var str = `.123
.000
.999
And want false for these cases
123
a123
.123a
.1234
a.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}