re = /^\.\d{3}$/m
str = '.123
.000
.999
And want false for these cases
123
a123
.123a
.1234
a.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end