#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Igroup Name:\s+((?:[\w-]+,\s*)*[\w-]+)"
Local $sString = "Address: c8245A626" & @CRLF & _
"AliasName: eSrb002359_f1" & @CRLF & _
"Igroup Name: rtvclar002359, unjlclar002358-9," & @CRLF & _
"cokeclar00RCB_FC" & @CRLF & _
"Protocol: REST"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")