const regex = /Igroup Name:\s+((?:[\w-]+,\s*)*[\w-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Igroup Name:\\s+((?:[\\w-]+,\\s*)*[\\w-]+)', 'gm')
const str = `Address: c8245A626
AliasName: eSrb002359_f1
Igroup Name: rtvclar002359, unjlclar002358-9,
cokeclar00RCB_FC
Protocol: REST`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}