import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Igroup Name:\\s+((?:[\\w-]+,\\s*)*[\\w-]+)";
final String string = "Address: c8245A626\n"
+ "AliasName: eSrb002359_f1\n"
+ "Igroup Name: rtvclar002359, unjlclar002358-9,\n"
+ "cokeclar00RCB_FC\n"
+ "Protocol: REST";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}