package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Igroup Name:\s+((?:[\w-]+,\s*)*[\w-]+)`)
var str = `Address: c8245A626
AliasName: eSrb002359_f1
Igroup Name: rtvclar002359, unjlclar002358-9,
cokeclar00RCB_FC
Protocol: REST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}