use strict;
my $str = '<u>teste agora <b>que</b></u>
';
my $regex = qr/([çqg])/mp;
my $subst = '</u>$1<u>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";