re = /([çqg])/m
str = '<u>teste agora <b>que</b></u>
'
subst = '</u>$1<u>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result