#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*\bMaster\b).* tells you, .*"
Local $sString = "(Soandso tells you, "Hello")" & @CRLF & _
"" & @CRLF & _
"But I need it to exclude any string containing the word "Master."" & @CRLF & _
"" & @CRLF & _
"(Yourpet tells you, "Attacking creature Master.")" & @CRLF & _
"" & @CRLF & _
"(Yourpet tells you, "The \b makes it only exclude the exact word, so this is found: Masterpiece.")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")