import Foundation
let pattern = #"(?!.*\bMaster\b).* tells you, .*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(Soandso tells you, "Hello")
But I need it to exclude any string containing the word "Master."
(Yourpet tells you, "Attacking creature Master.")
(Yourpet tells you, "The \b makes it only exclude the exact word, so this is found: Masterpiece.")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)