re = /(?!.*\bMaster\b).* tells you, .*/m
str = '(Soandso tells you, "Hello")
But I need it to exclude any string containing the word "Master."
(Yourpet tells you, "Attacking creature Master.")
(Yourpet tells you, "The \\b makes it only exclude the exact word, so this is found: Masterpiece.")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end