use strict;
my $str = '(Soandso tells you, "Hello")
But I need it to exclude any string containing the word "Master."
(Yourpet tells you, "Attacking creature Master.")
(Yourpet tells you, "The \\b makes it only exclude the exact word, so this is found: Masterpiece.")';
my $regex = qr/(?!.*\bMaster\b).* tells you, .*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}