using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*\bMaster\b).* tells you, .*";
string input = @"(Soandso tells you, ""Hello"")
But I need it to exclude any string containing the word ""Master.""
(Yourpet tells you, ""Attacking creature Master."")
(Yourpet tells you, ""The \b makes it only exclude the exact word, so this is found: Masterpiece."")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}