# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(?:\"|\'|)(?: )#?(.*)|(.*)//gmi;t' <<< "fdsfsf345#3gt#$%3^#$T$#tr43r43
test spaces
\"test spaces\"
\"fdsfsf345#3gt#$%3^#$T$#tr43r43\" #comment
\"test spaces\" #comment"