$re = '/(.*)(?:\"|\'|)(?: )#?(.*)|(.*)/mi';
$str = 'fdsfsf345#3gt#$%3^#$T$#tr43r43
test spaces
"test spaces"
"fdsfsf345#3gt#$%3^#$T$#tr43r43" #comment
"test spaces" #comment';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;