const regex = /(.*)(?:\"|\'|)(?: )#?(.*)|(.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(?:\\"|\\\'|)(?: )#?(.*)|(.*)', 'gmi')
const str = `fdsfsf345#3gt#\$%3^#\$T\$#tr43r43
test spaces
"test spaces"
"fdsfsf345#3gt#\$%3^#\$T\$#tr43r43" #comment
"test spaces" #comment`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);