#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(.*)(?:\"|\'|)(?: )#?(.*)|(.*)"
Local $sString = "fdsfsf345#3gt#$%3^#$T$#tr43r43" & @CRLF & _
"test spaces" & @CRLF & _
""test spaces"" & @CRLF & _
"" & @CRLF & _
""fdsfsf345#3gt#$%3^#$T$#tr43r43" #comment" & @CRLF & _
""test spaces" #comment"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)