package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(.*)(?:\"|\'|)(?: )#?(.*)|(.*)`)
var str = `fdsfsf345#3gt#$%3^#$T$#tr43r43
test spaces
"test spaces"
"fdsfsf345#3gt#$%3^#$T$#tr43r43" #comment
"test spaces" #comment`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}