# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(\d+)\s*x/\1/gm;t' <<< "13 x Ecobulb 7W 3000K B22 Non-Dim (CFL Replace) (front_entrance); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway)"