const regex = /\s*(\d+)\s*x/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(\\d+)\\s*x', 'gm')
const str = `13 x Ecobulb 7W 3000K B22 Non-Dim (CFL Replace) (front_entrance); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway)`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);