using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\d+)\s*x";
string substitution = @"\1";
string input = @"13 x Ecobulb 7W 3000K B22 Non-Dim (CFL Replace) (front_entrance); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}