re = /\s*(\d+)\s*x/m
str = '13 x Ecobulb 7W 3000K B22 Non-Dim (CFL Replace) (front_entrance); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway); 2 x Ecobulb 7W 3000K B22 Non-Dim (Reflector Replace) (front_hallway)'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result