const regex = /^([^0-9\n]*[0-9]){2}.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^0-9\\n]*[0-9]){2}.*', 'gm')
const str = `a 1 b 2 c
1 b 2 c
a 1 b 2
a 1 b 2 c 3 d 4 e
a 12
12 a b c
a 1 b
1
a b 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}