re = /^([^0-9\n]*[0-9]){2}.*/m
str = 'a 1 b 2 c
1 b 2 c
a 1 b 2
a 1 b 2 c 3 d 4 e
a 12
12 a b c
a 1 b
1
a b 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end