// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^0-9\n]*[0-9]){2}.*").unwrap();
let string = "a 1 b 2 c
1 b 2 c
a 1 b 2
a 1 b 2 c 3 d 4 e
a 12
12 a b c
a 1 b
1
a b 2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}