#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "'Model-last-Mode': '(.*)' }"
Local $sString = "<script type="text/javascript" " & @CRLF & _
"$.ajaxSetup({ " & @CRLF & _
"headers: { 'Model-last-Mode': 'yEDXSuK4yI8xJCVG0IW+sxp0Yvp2WmyxDuVo+ibRMxI=' } }); " & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")