import Foundation
let pattern = #"'Model-last-Mode': '(.*)' }"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<script type="text/javascript"
$.ajaxSetup({
headers: { 'Model-last-Mode': 'yEDXSuK4yI8xJCVG0IW+sxp0Yvp2WmyxDuVo+ibRMxI=' } });
</script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)