re = /'Model-last-Mode': '(.*)' }/
str = '<script type="text/javascript"
$.ajaxSetup({
headers: { \'Model-last-Mode\': \'yEDXSuK4yI8xJCVG0IW+sxp0Yvp2WmyxDuVo+ibRMxI=\' } });
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end