$re = '/\'Model-last-Mode\': \'(.*)\' }/';
$str = '<script type="text/javascript"
$.ajaxSetup({
headers: { \'Model-last-Mode\': \'yEDXSuK4yI8xJCVG0IW+sxp0Yvp2WmyxDuVo+ibRMxI=\' } });
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);