using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[a-z]+\w)";
string input = @"We are interested in the work of Alan Turing and Oscar Morgenstern, studying the theory of algorithms and probability theory.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}