package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[a-z]+\w)`)
var str = `We are interested in the work of Alan Turing and Oscar Morgenstern, studying the theory of algorithms and probability theory.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}