re = /(?:[a-z]+\w)/
str = 'We are interested in the work of Alan Turing and Oscar Morgenstern, studying the theory of algorithms and probability theory.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end