const regex = new RegExp('(?:[a-z]+\\w)', '')
const str = `We are interested in the work of Alan Turing and Oscar Morgenstern, studying the theory of algorithms and probability theory.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}