using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{0,72})";
string input = @"Sujeito a IPI (sem mensagem) MERCARDORIA COLETADA NO ARMAZEM GERAL CENTRO DE DISTRIBUICAO E LOGISTICA SENHORA DA PENHA S.A - CNPJ: 04.077.240/0003-07 - I.E: 255.382.148.113 RUA DOS TUCANOS,630 - GALPAO14 BAIRRO: SITIO GUAREHY - CARAPICUIBA / SP CEP: 063...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}