const regex = /(.{0,72})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{0,72})', 'gm')
const str = `Sujeito a IPI (sem mensagem) MERCARDORIA COLETADA NO ARMAZEM GERAL CENTRO DE DISTRIBUICAO E LOGISTICA SENHORA DA PENHA S.A - CNPJ: 04.077.240/0003-07 - I.E: 255.382.148.113 RUA DOS TUCANOS,630 - GALPAO14 BAIRRO: SITIO GUAREHY - CARAPICUIBA / SP CEP: 063...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}