re = /(.{0,72})/m
str = 'Sujeito a IPI (sem mensagem) MERCARDORIA COLETADA NO ARMAZEM GERAL CENTRO DE DISTRIBUICAO E LOGISTICA SENHORA DA PENHA S.A - CNPJ: 04.077.240/0003-07 - I.E: 255.382.148.113 RUA DOS TUCANOS,630 - GALPAO14 BAIRRO: SITIO GUAREHY - CARAPICUIBA / SP CEP: 063...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end