#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^\W_\d]+$)[^\W_]{9,}$"
Local $sString = "12345678987654567" & @CRLF & _
"jhsjd4567hsqdgqsgh456786576567kj" & @CRLF & _
"9l8j9n9k0n9n8n" & @CRLF & _
"loremipsum" & @CRLF & _
"a1" & @CRLF & _
"12567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")