import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^\\W_\\d]+$)[^\\W_]{9,}$";
final String string = "12345678987654567\n"
+ "jhsjd4567hsqdgqsgh456786576567kj\n"
+ "9l8j9n9k0n9n8n\n"
+ "loremipsum\n"
+ "a1\n"
+ "12567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}