const regex = /^(?![^\W_\d]+$)[^\W_]{9,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^\\W_\\d]+$)[^\\W_]{9,}$', 'gm')
const str = `12345678987654567
jhsjd4567hsqdgqsgh456786576567kj
9l8j9n9k0n9n8n
loremipsum
a1
12567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}