#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "classNames.*(.*{(?:.|\n)*?})"
Local $sString = "" & @CRLF & _
" const test = {" & @CRLF & _
" 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':" & @CRLF & _
" true," & @CRLF & _
" 'bg-blue-1/10 text-blue-1 border-blue-1': true," & @CRLF & _
" };" & @CRLF & _
"" & @CRLF & _
" className={classNames({" & @CRLF & _
" 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':" & @CRLF & _
" true," & @CRLF & _
" 'bg-blue-1/10 text-blue-1 border-blue-1': open," & @CRLF & _
" })}" & @CRLF & _
" >" & @CRLF & _
" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")