import Foundation
let pattern = #"classNames.*(.*{(?:.|\n)*?})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
const test = {
'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':
true,
'bg-blue-1/10 text-blue-1 border-blue-1': true,
};
className={classNames({
'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':
true,
'bg-blue-1/10 text-blue-1 border-blue-1': open,
})}
>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)