// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"classNames.*(.*{(?:.|\n)*?})").unwrap();
let string = "
const test = {
'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':
true,
'bg-blue-1/10 text-blue-1 border-blue-1': true,
};
className={classNames({
'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':
true,
'bg-blue-1/10 text-blue-1 border-blue-1': open,
})}
>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}