import re
regex = re.compile(r"classNames.*(.*{(?:.|\n)*?})")
test_str = ("\n"
" const test = {\n"
" 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':\n"
" true,\n"
" 'bg-blue-1/10 text-blue-1 border-blue-1': true,\n"
" };\n\n"
" className={classNames({\n"
" 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':\n"
" true,\n"
" 'bg-blue-1/10 text-blue-1 border-blue-1': open,\n"
" })}\n"
" >\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")