const regex = /classNames.*(.*{(?:.|\n)*?})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('classNames.*(.*{(?:.|\\n)*?})', 'g')
const str = `
const test = {
'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':
true,
'bg-blue-1/10 text-blue-1 border-blue-1': true,
};
className={classNames({
'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':
true,
'bg-blue-1/10 text-blue-1 border-blue-1': open,
})}
>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}