package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\p{sc=Han}+$|[а-яА-Я]+|[a-zA-Z]+)$`)
var str = `你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
Test
Test
Иванов
S1f你好jd
S1f 你好jd
Yury-sd
Юрий-
-Юрий
фывфвы-фывфыв
Юрий выв
Фа фФвSsыв
фФвSsыв`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}