re = /^(\p{sc=Han}+$|[а-яА-Я]+|[a-zA-Z]+)$/mi
str = '你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
Test
Test
Иванов
S1f你好jd
S1f 你好jd
Yury-sd
Юрий-
-Юрий
фывфвы-фывфыв
Юрий выв
Фа фФвSsыв
фФвSsыв'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end